博客
关于我
强烈建议你试试无所不能的chatGPT,快点击我
HDOJ 1059 Dividing
阅读量:5257 次
发布时间:2019-06-14

本文共 2894 字,大约阅读时间需要 9 分钟。

惊现多重背包!马上水掉

Dividing

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12116    Accepted Submission(s): 3394


Problem Description
Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value. 
Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.
 

Input
Each line in the input describes one collection of marbles to be divided. The lines consist of six non-negative integers n1, n2, ..., n6, where ni is the number of marbles of value i. So, the example from above would be described by the input-line ``1 0 1 2 0 0''. The maximum total number of marbles will be 20000. 
The last line of the input file will be ``0 0 0 0 0 0''; do not process this line.
 

Output
For each colletcion, output ``Collection #k:'', where k is the number of the test case, and then either ``Can be divided.'' or ``Can't be divided.''. 
Output a blank line after each test case.
 

Sample Input
1 0 1 2 0 0
1 0 0 0 1 1
0 0 0 0 0 0
 

Sample Output
Collection #1:
Can't be divided.
Collection #2:
Can be divided.
 

Source
 

Recommend
JGShining
 
#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
int a[7];
int pack[422222];
int V;
void zpack(int*a,int c,int w)
{
    for(int i=V;i>=c;i--)
        a
=max(a,a[i-c]+w);
}
void cpack(int*a,int c,int w)
{
    for(int i=c;i<=V;i++)
        a
=max(a,a[i-c]+w);
}
void multipack(int* a,int c,int w,int m)
{
    if(c*m>=V)
    {
        cpack(a,c,w);
        return;
    }
    int k=1;
    while(k<m)
    {
        zpack(a,k*c,k*w);
        m-=k;
        k*=2;
    }
    zpack(a,m*c,m*w);
}
int main()
{
    a[0]=1;
int cur=0;
while(a[0])
{
    int sum=0;
    for(int i=1;i<=6;i++)
    {
        scanf("%d",&a
);
        sum+=i*a
;
    }
    if(sum==0)  a[0]=0;
    if(a[0]==0) break;
 //   cout<<sum<<endl;
    if(sum&1)  { printf("Collection #%d:\n",++cur); puts("Can't be divided.\n"); continue;}
    memset(pack,0,sizeof(pack));
    V=sum/2;
    for(int i=1;i<=6;i++)
        multipack(pack,i,i,a
);
/*
 for(int i=0;i<=V;i++)
    cout<<pack
<<" ";
cout<<endl;
*/
    if(pack[V]==V)
    {
        printf("Collection #%d:\n",++cur); puts("Can be divided.\n");
    }
    else
    {
        printf("Collection #%d:\n",++cur); puts("Can't be divided.\n");
    }
}
    return 0;
}

转载于:https://www.cnblogs.com/CKboss/archive/2013/06/06/3351036.html

你可能感兴趣的文章
Python学习1--数据类型与循环要点
查看>>
c语言实验三(3)
查看>>
C++常见编译错误
查看>>
如何让你不成为仅仅是代码工人?
查看>>
JAVA遇见HTML——JSP篇(1、JAVA WEB简介)
查看>>
mysql事务
查看>>
mysql 优化
查看>>
Generate transparent shape on image
查看>>
长沙方言书面教材
查看>>
Jenkins + maven 设置
查看>>
mac屏幕录制
查看>>
批量---修改保存 (通用方法)
查看>>
Java 享元设计
查看>>
20145118 《Java程序设计》 第3周学习总结
查看>>
函数内部的两个特殊的对象:arguments和this
查看>>
MySQL 5.7安装与配置
查看>>
第四阶段 02_Linux简介
查看>>
window size in Windows User Experience Interaction Guidelines
查看>>
Using 1.7 requires compiling with Android 4.4 (KitKat); currently using API 8
查看>>
Logstic回归采用sigmoid函数的原因
查看>>